GNU Compiler Collection (GCC) 6 Now Enabled by Default in Debian Unstable

Datetime:2016-08-23 01:51:10          Topic: Debian           Share

Debian developer Emilio Pozuelo Monfort announced this past weekend the enablement of the GCC (GNU Compiler Collection) 6 compiler tools by default for Debian Unstable.

Back in June, the Debian devs were happy to announce that the latest GCC 6 and GNU Binutils 2.27 (or 2.28 if it will be released by then) will be the default on the upcoming Debian GNU/Linux 9 "Stretch" operating system, which is currently under heavy development, and available to early adopters from the Debian Testing channels.

And now, the Debian devs are also proud to inform the community that GCC 6 has been enabled by default in Debian Unstable, also known as Debian Sid, a rolling development version of the Debian GNU/Linux distribution. GCC 6.1.1 is currently the version available in those repos, along with the Boost 1.61 and ICU 57 libraries.

"As you have probably noticed, the default GCC has been changed to GCC 6 in unstable, as was announced last June. If your package still fails to build with GCC 6, now is the time to fix it," says Emilio Pozuelo Monfort on behalf of the Debian Release Team. "At the same time, ICU 57 and Boost 1.61 have been uploaded, and boost-defaults now points to Boost 1.61."

That being said, Emilio Pozuelo Monfort also informs the Debian community about the fact that rebuilds are currently ongoing and if your package happens to fail to build because of this, you're urged to analyze the issues and fix them as soon as possible. More details are available at https://bugs.debian.org/cgi-bin/pkgreport.cgi?tag=ftbfs-gcc-6;users=debian-gcc@lists.debian.org .





About List