Audacious 3.8 Beta 1 Released, Available In PPA

Datetime:2016-08-23 04:20:45          Topic:          Share

Audacious 3.8 beta 1 was released a couple of days ago and is available in the WebUpd8 Unstable PPA. The new version brings support for running multiple Audacious instances, a new plugin for the Qt interface, and various other improvements and bug fixes.

Audacious GTK2 interface

Audacious is an audio player that focuses on high audio quality and low resource usage. It ships with numerous plugins and 3 interfaces: a GTK (the PPA packages are built with GTK2) interface, a Qt interface, and a Winamp 2.x like interface (it supports Winamp 2.x skins).

Changes in Audacious 3.8 beta 1:

  • the app now supports multiple instances, each with its own configuration. To start a new instance, run "audacious -N". The audtool command can control the instance with "audtool -1 " for instance one, "-2" for the second instance, etc.;
  • Qt interface: new plugin that allows browsing music on an Ampache server;
  • new audtool commands have been added:
    • enable/disable stream recording;
    • enable/disable any plugin: effects, visualizations, etc.;
  • cuesheet support is more seamless, with the following fixes:
    • more robust logic to prevent adding duplicate entries;
    • display artist correctly for cuesheets with only a single PERFORMER line;
    • add audio files normally if cuesheet support is disabled;
    • track lengths correctly account for pregap with libcue 2.0 or later;
  • deatures ported to the Qt interface:
    • context (right-click) menu in the playlist;
    • copy-and-paste of playlist entries;
    • open Containing Folder command;
    • desktop notifications and file deletion (with the appropriate plugins);
    • access to the full set of FileWriter options;
  • folders can be added from various URI protocols (ftp, mtp, etc.) via GIO;
  • audio effects and equalization can optionally be applied to a stream recording;
  • option to display MMM:SS instead of H:MM:SS;
  • automatic selection of the best available output bit depth;
  • album artist support for FLAC and Vorbis files (read-write);
  • support for the freedesktop.org startup notification protocol;
  • better Windows support: new installer, audio output now uses the native waveOUT API which allows higher bit depths, lower latency, and better system volume control integration;
  • various bug fixes.

Check out the official Audacious 3.8 beta 1 release announcement  HERE .

Since Audacious 3.8 is in beta, I didn't upload it to the main WebUpd8 PPA, but to the Unstable / Backports PPA . There are packages for Ubuntu 16.10 Yakkety Yak, as well as Ubuntu 16.04 and 14.04.

The new Ampache Browser plugin is only available for Ubuntu 16.10 and 16.04 (and only for the Audacious Qt interface), because libampache-browser , which is required by this plugin, fails to build in older Ubuntu versions.

Here's a screenshot of the new Ampache Browser plugin in action, using its built-in demo server (using the Audacious Qt interface):

Install Audacious 3.8 beta 1 in Ubuntu or Linux Mint

Audacious 3.8 is in beta, so you might encounter bugs! You may want to use the latest stable Audacious (3.7.2), available in themain WebUpd8 PPA.

To add the WebUpd8 Unstable / Backports PPA and install (or upgrade to) Audacious 3.8 beta 1 in Ubuntu or Linux Mint, use the following commands:

sudo add-apt-repository ppa:webupd8team/unstable
sudo apt update
sudo apt install audacious
For other Linux distributions and Windows, see the Audacious download

page.